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Course Sparx ® Enterprise Architect

SPARX® Enterprise Architect helps individuals, groups and
large organizations model and manage complex
information. By integrating and connecting a wide range
of structural and behavioral information in visual form,
you can build an end-to-end coherent, verifiable model
of what-is or what-will-be for every role in your
organization.

Enterprise Architect is a trademark 
of Sparx Systems PTY LTD.
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Part I: Introduction

 Enterprise Architeture

 End-to-end Framework
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Introduction  - Enterprise Architecture 

Business Architecture / Enterprise Architecture is a relative young profession
although a lot happened last 10 years. There were a lot of architecture methods,
techniques and frameworks, a lot of them were developed by consulting/advisory
organizations and not publicly available.

In essence Enterprise Architecture is about the guidance of decision making on
both short and long term changes. Since every architect, manager and designer
have their own language it is evident that there is a need to create a unified way
of communicating

That's why there is a clear trend towards open institutes with open standards.

INTRODUCTION
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Gartner – Magic  Quadrant for Enterprise Architecture Tools

INTRODUCTION

Market Definition / Description

Enterprise architecture (EA) tools are
software applications designed to
support enterprise architects and other
business and IT stakeholders with
strategically driven planning, analysis,
design and execution.

EA tools support strategic and tactical
decision making by capturing and
connecting context and information
across business, information, solution
and technology domains, along with
other relevant architectural viewpoints.
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Gartner – Magic  Quadrant for Enterprise Architecture Tools

Strengths

 Sparx Systems’ business model of downloadable software fits perfectly with its strategy
of being a low-license-cost provider. It is very consistent in this regard, and has not
raised its prices for eight years. The product focuses mainly on the core capabilities of
the EA tool market and targets foundational enterprise architects whose needs are best
matched by those capabilities.

 Sparx Systems has made some improvements to its product strategy since 2017. For
example, it is increasing support for business modeling and analysis by developing a
UML profile for the Business Architecture Body of Knowledge (BIZBOK). It also launched
the Pro Cloud Server, which enables users to view models and content from a web-
enabled location.

 Sparx Systems launched its Global Sparx Services Arm in 2018 as part of its sales
strategy. Its aim is to increase telesales operations and provide remote demonstrations,
while offering to support on-site proof-of-concept assessments.

INTRODUCTION
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Gartner – Magic  Quadrant for Enterprise Architecture Tools

Cautions

 Sparx Systems has no full, hybrid cloud offering, despite its release of Pro Cloud Server.
The functionality is installed on-premises, while the repository is accessed through a
simple URL connection. On an enterprise level, this can be challenging; however, it works
fine for small groups of active users within an organization.

 Sparx Systems does not fully provide many of the critical capabilities supported by other
vendors, although it adequately covers core capabilities. It usually incorporates critical
capabilities when they are becoming mainstream. This is because its customer base is
situated more in the “late majority” segment of this market.

 Sparx Systems still offers a lower level of customer support than other vendors in this
market. It provides direct technical support by email, meaning most software issues are
addressed overnight (given the time zone difference between Australia and the rest of
the world). The vendor has begun to improve this — some partners and the Global
Sparx Services Arm can provide telephone support during business hours — but it does
not provide fully global, 24/7 support.

INTRODUCTION
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Introduction  - Tool  - Sparx E.A. Methods & Notations 30+ 

BPA

BPMS

BPM

EA

Targets                                   Services            Applications
& Vision       Departments  & Processes     &  Systems     Databases       Datastructure

Simulate       To-Be Proces            Analyse
Optimalisation of  
business processes

Automatisation of  
business processes

Execute         Monitor                  Execute Manage

Enterprise
Architecture

Business Proces
Analyses

Business Proces
Management

Business Proces
Management System

BPMN

BPEL

INTRODUCTION
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Introduction  - Tool  - Sparx E.A. Repository

Sparx Enterprise Architect works with a Repository, this can be physical file (extension .eap)
or this can be with a database (ex. ORACLE, MS, …), or this can be a database in the cloud.

Advantages when working with a Repository:

- Define ONCE re-use MULTIPLE
- Use item in different projects
- Use item with different users / analysts

- Define ONCE re-use LINKS
- Use item in other diagrams
- Use item in overviews

- WORK on the same model / view

INTRODUCTION
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Goal today: Building an End-to-end Framework Model

INTRODUCTION
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Part II: The preparation

 Introduction

 Editions, price  & versions

 A new / existing project

 Renaming your project

 The environment

 The notation formats sa. UML, BPMN, ARCHIMATE, …

 Show Grid

 Changing Themes / Colors schemas
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Editions

Enterprise Architect also comes in different versions. For your own
evaluation you can review what each edition offers in detail by
selecting the Help at the initial set up screen the first time you
run the application.

Enterprise 
Architect 
Editions

Extended
Suite

Editions

For this course and manual,
we use the Corporate
version.

PREPARATION
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Price (01/2020)

Enterprise Architect prices depends on Named User License or Floating Edition.

PREPARATION



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 14p.

Creating a new project

The first step in getting started with Enterprise Architect is to either open an existing
project, or create a new one.

Choice of Repository:

Models can be stored in either a file based repository or a DBMS repository.
 File based Repository
 DBMS

File based Repository
 Enterprise Architect Project / JET 4 Base Projects (*.eapx) – Newly introduced in 

Enterprise Architect 14.
• Enterprise Architect Project / JET 3.5 (*.eap).
• Enterprise Architect Project / Firebird (*.feap).

PREPARATION
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Creating a new project

In Enterprise Architect 14 Sparx Systems has added support to Jet 4 base projects by
introducing *.eapx file. Jet 4 databases support Unicode. Previous versions of Enterprise
Architect 14 supported in Jet 3.5 database which doesn’t support Unicode.

Also the advantage of using *.eapx file is in some circumstances database corruption would
cause a Jet 3.5 model to fail to open in Jet 3.5 code, but Jet 4 code ignores or handles the
error.

The benefits of this repository type are:
 Replication of the repository.
 Simple file access across a shared network drive.

The limitations of this repository type to consider are:
 Concurrent access is limited to small groups of users.
 Data corruption can occur if there is a network/power failure while editing.
 There are limitations on the data size supported by the Jet database (less than 30-40 mb

is recommended).

PREPARATION
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DBMS Repository

Using a DBMS repository overcomes the limitations of file-based repositories. Typically,
dedicated DBMS servers provide faster response times for a larger user base than the file
based repositories.

Further, any network errors are handled by the ability of the DBMS server to roll back
transaction failure caused by external conditions.

DBMS repositories can be accessed from a Cloud service. Although replication is not 
supported with DBMS repositories, with the Cloud connectivity replication is largely 
superseded. Enterprise Architect supports the 10 most popular types of DBMS server 
repositories.

You can set up your project on a repository in:
 MySQL from v5.
 Microsoft SQL Server from 2005, all editions including Express and Azure.
 Oracle from 9i (all editions).
 Firebird from v2.
 Microsoft Access from 2007.
 PostgreSQL from v8.
 Sybase Adaptive Server Anywhere 8 or 9, or SQL Anywhere 10, 11 or 12.

PREPARATION
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Setting your environment to work

Before we are going to work on our model we want to set our environment.
This is off-course dependent on your preferences, but we suggest this:

(1) Diagram Toolbox (2) Work screen (3) Project Browser (4) Notes

1

PREPARATION

2

3

4
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Setting your environment to work: Notes

If Notes is not on your screen, you can activate it by selecting from the menu:
Start > Window > Notes

4

PREPARATION
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Setting your environment to work: Notes

Now that Notes is on your screen, you can select if you want the notes window to
Dock (stay on the same place) of the notes window to Float (Movable).

You can also select for Autohide, then the Notes
icon will appear vertical on the right of the screen
and will become visible when you go over with
your mouse

4

PREPARATION
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Setting your environment to work: Project Browser 

If Project Browser is not on your screen, you can activate it by selecting from the
menu: Start > Window > Project Browser

4

PREPARATION
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Setting your environment to work: Diagram Toolbox

If Toolbox is not on your screen, you can activate it by selecting from the menu:
Right mouse on Start > Diagram Toolbox

1

PREPARATION
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Setting your environment to work: Diagram Toolbox

Within Toolbox you can select for the Notation format you want, there are about
40 possibilities.
More tools > …

1

PREPARATION
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Setting your environment to work: Show Grid

By selecting Layout > Appearance > Options you can enable or disable the Grid
function.

PREPARATION
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Setting your environment to work: Snap to Grid

By selecting Layout > Appearance > Options you can enable the Snap to Grid
function.

PREPARATION
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Setting your environment to work: Show Grid

By selecting Layout > Appearance > Options you can enable or disable the Grid
function.

PREPARATION
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Changing Themes / Colors schemas

To change the colors to a predefined SET (Theme), select Layout > Appearance > 
Options you can enable the Themes function.

PREPARATION
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Changing Themes / Colors schemas

To change the colors to a predefined SET (Theme), select Layout > Appearance > 
Options you can enable the Themes function.

PREPARATION
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Part III: The modeling

 Add / Change / Delete a View To Your Model
 Archimate, BPMN, UML Views

 Add / Change / Delete a Package To Your Model
 Package your existing / new Actors & Roles
 Move elements in a Package in Your Model

 Add / Change / Delete a Diagram To Your Model
 Add Diagram details To Your Model
 Add Authors details To Your Model
 Add an Element To Your Model / Diagram
 Enterprise Architect Model Structure Checklist 
 Generation of the content of packages into a Diagram
 Create and Change connectors in Diagrams

 Visibility, color,  directions, multiplicity
 Organize a number of elements in a Diagrams
 Creating Real and Virtual Actors in Diagrams
 Generalization, specialization of Actors in UML
 Creating and changing Flows in Diagrams
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Add a View / Package / Diagram / Element To Your Model (1)

A View is a top level package, within a model. It can be categorized by purpose
using different icon types, such as Use Case View, Component View or
Deployment View. Views are used to contain packages, diagrams and elements -
the building blocks of your model

Add a view by selecting, Design > Model Wizard or New or in the Project
Browser

MODELING
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Add a View / Package / Diagram / Element To Your Model (2)

Choose for example an Archimate toolbox set.

An Archimate view is added into
the Project Browser

MODELING
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Change the Order of View Of Your Model

By using the arrows in the Project Browser Menu, you can change the
order of the views of your model

MODELING
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Delete a View / Package / Diagram / Element Of Your Model

Select in the Project Browser the view you want to delete, click the right mouse
button and select for Delete.

MODELING
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Move Packages / Diagrams / Elements in Your Model

Reorganize and optimize .

MODELING
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Add a Diagram To Your Model  

A Diagram is a visual representation of The elements of your model - Their
attributes and characteristics - How they are connected and/or interact with each
other.
Different diagram types show different aspects of the model and the relationships
between elements.

Add a diagram by selecting from the Project Browser Menu:
New Diagram

MODELING
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Add Diagram details To Your Model: General

Click right mouse button on your diagram and select for properties.

Select Diagram and select Show 
Diagram Details

MODELING
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Add Authors details To Your Model

Select Configure | Resources | Project Types | People  and select Project 
Author(s) to add a new Author of diagrams to your team.

MODELING
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Enterprise Architect Model Structure Checklist:

Start-up Enterprise Architect and arrange work environment:

Start-up a new project and choose file-name

Add views (ArchiMate, UML , BPMN, … ) to the project

Add packages to your model

Add diagrams to your packages

Add elements to your diagram

1

2

3

5

6

4

MODELING



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 38p.

Enterprise Architect Model Structure Icons:

A possible structure of your Project.

Project

View 1

Package 1

Package 2

View 2

Package 3

Package 4

Diagram 1

Diagram 2

Diagram 3

Elements 1, 2, 3, 4 …

MODELING
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Generation of the content of packages into a Diagram

Throw the Package onto your diagram

The diagram generates the content of its two packages (Actors, Primary Use
Cases).

MODELING
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Creating connectors in Diagrams: Flow between 2 existing objects

Creation of a flow can enhance your model.

Step 1: a. Select the Object and click on the arrow
b. Connect it with the other object
c. Select the sort of connection

a.

b.

Flow 
dependent on 

object

MODELING
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Creating connectors in Diagrams: Flow between 1 existing  and 1 new
object

Creation of a flow can enhance your model.

Step 1: a. Select the Object and click on the arrow
b. Pull the arrow for 2 centimeter, but do not connect
c. Select which (New) object to connect to and how to connect

a.

b. c.

Symbol 
dependent on 

object
Flow 

dependent on 
object

MODELING
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Change connectors (direction, arrows, names, .. ) in Diagrams

Change properties of the flow, by double clicking the line

MODELING
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Change connectors (bend line at Cursor, .. ) in Diagrams

Change properties of the flow, by clicking right mouse button

REMARK: In the line custom mode, you can also bend a line by selecting a
point on the line and clicking the left mouse button.

MODELING
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Change connectors (straighten Line at Cursor, .. ) in Diagrams

Change properties of the flow, Right-clicking at a Line point displays the Straighten
Line at Cursor context menu option, which you can use to remove the line point.

REMARK: In the line custom mode, you can also straighten a line by selecting a
point on the line and clicking the left mouse button.

MODELING
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Change Colors and thickness of connectors in Diagrams

Change properties of the flow, by clicking right mouse button

MODELING
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Change Visibility (Hide) of connectors in Diagrams

Change properties of the flow, by clicking right mouse button

MODELING
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Change Visibility (Show) of connectors in Diagrams

Double-click on the required diagram element in the Diagram view.
The element Properties dialog displays, Select the Links tab.
This lists the connectors linked to the element, whether or not they are hidden on 
the diagram. Right-click on the connector to hide or show

MODELING



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 48p.

Change Multiplicity of connectors in Diagrams 

Double-click on a connector to open the Connector Properties dialog.
Select the General and Role(s) page.
Enter the required details and click on the OK button.

MODELING
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Organise a number of elements in a Diagrams  (1)

Select the elements of the Diagram you want to organise.
(method 1: Select by Pressing the SHIFT key and the elements)
(method 2: Select by Left mouse button and select the elements)
Select the Organise option, here ‘ Align bottom ‘.

MODELING



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 50p.

Organise a number of elements in a Diagrams  (2)

MODELING
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Find an element in a The Project Browser

Select the elements of the Diagram, Click right mouse button.
Choose for  Find and then  In Project Browser

MODELING



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 52p.

Find an element in All Diagrams

Select the element in The Project Browser, Click right mouse button.
Choose for Find in All Diagrams.

MODELING
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Creating Real and Virtual Actors in Diagrams  (1)

Creation of Virtual Actors can enhance your model.

Step 1: Create your Real Actors

Step 2: Add your Virtual Actors Step 3: Color your Actors (optional)

MODELING
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Creating Real and Virtual Actors in Diagrams  (2)

Creation of Virtual Actors can enhance your model.

Step 3: Draw your Real and Virtual Actors Hierarchically (Generalization)

MODELING
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Creating Real and Virtual Actors in Diagrams  (3)

Creation of Virtual Actors can enhance your model.

Step 4: Organize your Real and Virtual Actors

MODELING
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uc Actors Ov erv iew Diagram

Insurance

Internal Actors

Human Actors

Client

External Actors

MODELING
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Part IV: Extended modeling

 Creating deeper (composite) levels in Diagrams
• Creating deeper (composite) levels in Data
• Turn On Level Numbering - (Turn Off Level Numbering)
• Apply auto naming of elements
• Adding hyperlinks in Diagrams
• Adding documents in Diagrams
• Re-use of Real and Virtual Actors in Diagrams (method 1)
• Re-use of Real and Virtual Actors in Diagrams (method 2)
• Working with instance Classifiers
• Re-use gives use the possibility of generating an impact 

analysis
• Glossary
• Working with an Alias
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Creating deeper (composite) levels in Diagrams  (1)

Step 1: Create normal flow.

EXTENDED MODELING
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Creating deeper (composite) levels in Diagrams  (2)

Step 2: Select the element and make a composite structure of it.

EXTENDED MODELING
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Creating deeper (composite) levels in Diagrams  (3)

Step 3: Model the deeper level

EXTENDED MODELING
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Creating deeper (composite) levels in Diagrams  (4)

Step 1: Create normal flow.

Step 2: Select the element and make a composite structure of it.

EXTENDED MODELING
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Creating deeper (composite) levels in Diagrams  (5)

Step 3: Model the deeper level

EXTENDED MODELING
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Creating deeper (composite) levels in Data (1)

Model the Data in an Business Analysis and the data in the Functional Analysis.

EXTENDED MODELING
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Turn On Level Numbering - (Turn Off Level Numbering)

Select a package and click the right mouse button and select Advanced -> Turn
On Level Numbering

Add a sequence number to
each element in the
package, based on the
element's position in the
package hierarchy. For
nested elements, the
numbering indicates level;
that is:

3.1
3.2
3.2.1
3.2.1.1

This option is only available
for packages, and the
numbering only applies to
the elements in the
package, not diagrams.

If elements are added,
moved or deleted from the
package, the numbering
automatically adjusts.

EXTENDED MODELING
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Apply auto naming of elements (1)

Select a package and click the right mouse button and select Advanced -> Apply
auto naming to elements

 Select all the Activities

 Include sub packages

 Auto Name Counters and select a Name

 Save the Name convention and Close

 Press OK

EXTENDED MODELING
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Apply auto naming of elements (2)

The result:

EXTENDED MODELING
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Adding hyperlinks in Diagrams

Select the Hyperlink icon and fill in the Hyperlink Details

EXTENDED MODELING



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 68p.

Adding documents in Diagrams  (1)

Select the Document icon and fill in the Document Details

EXTENDED MODELING
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Adding documents in Diagrams  (2)

Select the Document icon and open it for the first time

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 1)

Define the Actors.

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 1)

 Select the Real or Virtual Actor in the Project Browser (in this case ‘Insurance’)
 Drag the Real or Virtual Actor on to the Work screen
 Choose for Link in the Paste Element window

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 1)

 The Actor name is as defined in “ from Actors “

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 1)

 When renaming the Actor name all derived Actors will also change

EXTENDED MODELING
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Re-use gives use the possibility of generating an impact analysis  (1)

 Select the Actor you want to change/report/
 Press right mouse button and select ‘ Find in all diagrams ‘

EXTENDED MODELING
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Re-use gives use the possibility of generating an impact analysis  (2)

 Enterprise Architect will list where the Actor is also used …

EXTENDED MODELING
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Re-use gives use the possibility of generating an impact analysis  (3)

 And it is possible to click through and go to that specific diagram

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 2)  (1)

Define the Actors and the Lanes.

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 2)  (2)

Select the Lane of the Diagram, Click right mouse button.
Choose for  Advanced  and then for  Instance Classifier.

EXTENDED MODELING
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Re-use of Real and Virtual Actors in Diagrams (method 2)  (3)

Choose the first Actor the Lane represents ( Client in this case ).
Then press  OK .
Choose the second Actor the Lane represents ( Insurance in this case ).
Then press  OK .

EXTENDED MODELING
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Re-use gives use the possibility of generating an impact analysis

 And it is possible to click through and go to that specific diagram

EXTENDED MODELING
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Glossary

Choose for  Publish and then  Glossary

 Press right mouse button and select Add New …

 Then fill in the Term, the Type ( or create a new type ), the Meaning and
press OK.

 A new item is created

EXTENDED MODELING
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Glossary

The Glossary in the Notes can now be accessed from every where

EXTENDED MODELING
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Working with an Alias

Model a diagram and give every element in this diagram a Name and an Alias
Name.

EXTENDED MODELING
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Working with an Alias

Change the diagram to Alias Names. Press on the diagram the right mouse 
button and select for ‘Use Alias if available’.

Your diagram is now in Dutch
Pools, Lanes, Events, Activities, 
DataStores, .. Change language.

EXTENDED MODELING
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Part V: Functions

 Generate Diagram of Related elements 
 Export of (part of) Diagrams
 Export format XMI  (XML Metadata Interchange)
 Import of (part of) Diagrams
 Import a CSV file
 Export a CSV file
 Printing of (part of) Diagrams in RTF
 Printing of (part of) Diagrams in HTML
 Printing of (part of) Diagrams in Diagrams Only 
 Simulation of diagrams
 Relationship Matrix
 Place a Relationship Matrix link on your Diagram 
 Image Manager
 Creating, save, use and import a profile 
 Working with Baselines
 Version Control in EA
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Generate Diagram of Related elements (1)

The aim is to combine related elements/diagrams to 1 complete diagram.

First create different diagrams with a related element.

Business Process Links1

BusinessActor1

BusinessProcess1

Business Process Links2

BusinessProcess1

ApplicationComponent1

Business Process Links3

ApplicationComponent1

Device1

Network1

SystemSoftware1

FUNCTIONS
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Generate Diagram of Related elements (2)

Drag an element into your work screen to start from, then Click right mouse button 
on this element and select Insert Related Elements.

- Select 5 levels.
- Select All.
- Then Select OK and 

generate the Diagram.

FUNCTIONS
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Generate Diagram of Related elements (3)

The generated diagram will look like this.

Starting from the first selected elements,
E.A. has generated 4 levels deep.

Level 4

Level 2

Level 1

Level 3

FUNCTIONS
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Export of (part of) Diagrams

Select the   part of the diagram   you want to Export to XMI (select the package).

FUNCTIONS
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Export format XMI  (XML Metadata Interchange)

XMI (XML Metadata Interchange) is a proposed use of the Extensible Markup
Language (XML) that is intended to provide a standard way for programmers and
other users to exchange information about metadata (essentially, information about
what a set of data consists of and how it is organized). Specifically, XMI is intended
to help programmers using the Unified Modeling Language (UML) with different
languages and development tools to exchange their data models with each other.
In addition, XMI can also be used to exchange information about data warehouses.
Effectively, the XMI format standardizes how any set of metadata is described and
requires users across many industries and operating environments to see data the
same way.
XMI is a proposal from the Object Management Group (OMG) that builds on and
extends these industry standards or recommendations

FUNCTIONS
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Import of (part of) Diagrams

Select the XMI file you want to Import to E.A.

FUNCTIONS
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Import & Export of (part of) Diagrams

Another way of navigation, select Publish and then Export XMI

FUNCTIONS
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 Make a MS Excel file with your requirements

 Save this MS Excel file as a comma delimited file with 
extension *.csv

 The MS Excel comma delimited file then looks like

Import a CSV file : Make the CSV file

FUNCTIONS
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 Make To import the file into Enterprise Architect, you need to create a CSV import structure 
that corresponds to the columns in the CSV file. To do this, select from the main menu 
‘Publish > CSV Import/Export Specifications’

 Give the structure a name
 Create the structure

Import a CSV file : Define the CSV file

 Pay attention that the elements
have the same structure and
names then the Excel CSV file.

FUNCTIONS
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 To start the import process, select from the main menu ‘Package| Model Import/Export | 
CSV Import/Export’. This invokes the following window ready for you to enter information 
needed to perform the import.

Import a CSV file : Import the CSV file

FUNCTIONS
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 To export the file from Enterprise Architect, you need to create a CSV export structure that 
corresponds to the columns in the CSV file. To do this, select from the main menu ‘Package 
| Model Import/Export | CSV Import/Export Specifications’

 Give the structure a name
 Create the structure

Export a CSV file : Define the CSV file

FUNCTIONS
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 To start the export process, select from the main menu ‘Package | Model Import/Export | 
CSV Import/Export’. This invokes the following window ready for you to enter information 
needed to perform the export.

Export a CSV file : Export the CSV file

FUNCTIONS
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 Read the export file, generated by Enterprise Architect.

Export a CSV file : Read the exported CSV file

FUNCTIONS
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Printing of (part of) Diagrams  (1)

Printing a single diagram

The functions in the “File” menu are
used to print the current diagram.

Use “Print Setup…” to set EA to use A4
paper.

Use “Page Setup…” per diagram to the
diagram to Landscape or Portrait.

There is a Print Preview mode, and you
can print directly to a printer or print to
PDF.

FUNCTIONS
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Printing of (part of) Diagrams  (2)

Generate a report of a package in RTF

Select the Package of the Diagram, Click right mouse button.
Select Documentation and Rich Text Format Report.

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 101p.

Printing of (part of) Diagrams  (2)

Generate a report of a package in RTF

Select the Package of the Diagram.
Select Document and Generate Documentation.

FUNCTIONS
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Printing of (part of) Diagrams  (3)

Generate a RTF report

When EA generates documentation in RTF format, the number of settings is huge
and can be changed in ‘Options’, a lot of testing is required.

FUNCTIONS
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Printing of (part of) Diagrams  (4)

Generate a report of a package in HTML

Select the Package of the Diagram, Click right mouse button.
Select Documentation and HTML Report.

FUNCTIONS
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Printing of (part of) Diagrams  (4)

Generate a report of a package in HTML

Select the Package of the Diagram, Click right mouse button.
Select Publish and Standard HTML Report.

FUNCTIONS
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Printing of (part of) Diagrams  (5)  

Generate a HTML report

When EA generates documentation in HTML format, the number of settings is huge
and can be changed in ‘Options’, a lot of testing is required.

FUNCTIONS
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Printing of (part of) Diagrams  (6)

Generate a report (of Diagrams only)

Select the Package of the Diagram, Click right mouse button.
Select Documentation and Diagrams Only Report.

FUNCTIONS
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Printing of (part of) Diagrams  (6)

Generate a report (of Diagrams only)

Select the Package of the Diagram, Click right mouse button.
Select Documentation and Diagrams Only Report.

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 108p.

Printing of (part of) Diagrams  (7)

Generate a report (of Diagrams only)

When EA generates documentation in RTF – Diagrams only format, there are no
options to change.

FUNCTIONS
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Simulation of Diagrams

The Model Simulator is a tool in Enterprise Architect's Visual Execution
Analyzer, enabling you to simulate the execution of conceptual model designs
containing behavior. It provides a quick and simple way to verify your design's
behavior for logical correctness.

Platforms supported:

The Model simulator supports the following simulation platforms:

 UML
 State
 Activity
 Sequence

 BPMN
 Business Process

FUNCTIONS
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Simulation of Diagrams

Choose for Analyzer and then Execution Analyzer.

Select New (Add new script).

Select the Option Evaluate Guards ‘has to be ON’

FUNCTIONS
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Simulation of Diagrams

Define your diagram in UML / BPMN and choose for Analyzer and then Simulator.

FUNCTIONS
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Simulation of Diagrams

Choose for Simulate and then use the buttons.

FUNCTIONS
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Simulation of Diagrams

The Simulator starts up.

FUNCTIONS
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Simulation of Diagrams

The Simulator buttons:

MANUAL Choose the Manual Mode

Start the simulation.

Interrupt (pauze) the simulation.

The simulation’s runtime execution rate.

Stop the simulation.

Step over the next statement.

Step into the next statement.

Step out the current statement.

FUNCTIONS
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Simulation of Diagrams

Define Breakpoints in your Simulation.
Start-up the Breakpoint & Events window.

FUNCTIONS
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Simulation of Diagrams

Define Breakpoints in your Simulation.
Start-up the Simulate & Breakpoints window.

FUNCTIONS
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Simulation of Diagrams

Select the Breakpoint element on the diagram and select and enable the green
Breakpoint button.

During the simulation the
simulation will stop at
every enabled Breakpoint.

FUNCTIONS
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Simulation of Diagrams

Select the Breakpoint element on the diagram and select and enable the green
Breakpoint button.

Enable all the Breakpoints in the SET.

Delete all the Breakpoints in the SET.

Disable all the Breakpoints in the SET.

FUNCTIONS
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Relationship Matrix  (1)

Draw the diagram

FUNCTIONS
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Relationship Matrix  (2)

Select Tools and Relationship Matrix

Define the Source & Target code
Define the Source & Target element
Define the Link Type between the Source & Target
Define the Link Direction between the Source & Target

FUNCTIONS
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Relationship Matrix  (2)

Select Design and Relationship Matrix

Define the Source & Target code
Define the Source & Target element
Define the Link Type between the Source & Target
Define the Link Direction between the Source & Target

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 122p.

Relationship Matrix  (3)

Generation of the Relationship Matrix

REMARK
This works also over a combination of packages.

FUNCTIONS
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Place a Relationship Matrix link on your Diagram (1)

Create the Relationship Matrix as before

Save the Relationship Matrix as a New Profile, Options > Profiles > Save As

Go in the Project Browser to your specific Diagram and choose the hyperlink
from your Toolbox (common)

FUNCTIONS
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Place a Relationship Matrix link on your Diagram (2)

Choose as Type for Matrix and as Matrix Profile the name you just saved, and
press OK.

Give an Alias name for on the screen It looks like this

FUNCTIONS
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Image Manager  (1)

Create diagrams with images contained in the Image Library.
Select Project -> Settings -> Images … for image library.

FUNCTIONS
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Image Manager  (1)

Create diagrams with images contained in the Image Library.
Select Configure -> Images … for image library.

FUNCTIONS
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Image Manager  (2)

Create diagrams with images contained in the Image Library.

Select  Add New  for adding a new image.

Select  the new image and press OK.

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 128p.

Image Manager  (3)

The new image is now loaded in the Image Library.

FUNCTIONS
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Image Manager  (4)

Draw a diagram and select the element to be changed.

Select Alternate Image out of the menu.

FUNCTIONS
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Image Manager  (5)

The initial element has been changed with the selected element out of the Image
Manager.

FUNCTIONS
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Creating a Profile (1)

 Create a ‘Simple View Package‘ in your Project Browser,
with the name ‘Profiles’.

 Add an ‘UML Structural / Class‘ diagram, with the
name ‘Profiles’.

 Go to the Toolbox and select the ‘Profile’ toolset.

FUNCTIONS
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Creating a Profile (2)

 Create a Profile Package with the name
‘stereoTypeProfile’

 and put in an ‘UML Structural /
Class‘ diagram, with the name 
‘stereoTypeProfile’.

FUNCTIONS
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Creating a Profile (3)

 Enter the Class Diagram ‘stereoTypeProfile’

 Use the ‘MetaClass’ of the Toolbox

 and choose for ‘Requirement’  in the core elements.

MetaClass
=

MASTER
Blueprint

FUNCTIONS
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Creating a Profile (4)

 Use the ‘Stereotype’ of the Toolbox and give ‘MyRequirement’ as Name.

 We have now a:

- <<metaclass>> Requirement

- <<stereotype>> MyRequirement

StereoType
=

New Blueprint 
for the new 

element

FUNCTIONS
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Creating a Profile (5)

 Extend MyRequirement, start from
MyRequirement

 Add an attribute named ‘Description’ with Type ‘char’  
and Save this attribute .

We now created a stereotype

FUNCTIONS
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Creating a Profile (6)

 Use the ‘MetaClass’ of the Toolbox and choose for ‘Association’  in the core 
connectors.

 Use the ‘Stereotype’ of the Toolbox and give ‘MyAssociation’ as Name.

FUNCTIONS
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Creating a Profile (7)

 Extend the Class (start from MyAssociation).

We now created a profile

FUNCTIONS
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Save the Profile (8)

 Save the Model

 Click right mouse button
on the diagram
and ‘Save the Profile’.

 Choose ‘Profile Name’
and location of the XML
file.

We now saved a profile

FUNCTIONS
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Save the Profile (8)

 Save the Model

 Choose ‘Profile Name’
and location of the XML
file.

We now saved a profile

FUNCTIONS
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Import the Profile (9)

 Select from Project ‘Resources’. 

 Choose for UML Profiles and click right mouse
button ‘Import Profile’.

We now imported the profile

FUNCTIONS
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Import the Profile (9)

 Select Configure > Resources > 

 Choose for UML Profiles and click right mouse
button ‘Import Profile’.

We now imported the profile

FUNCTIONS
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Use the Profile (10)

 Select ‘More tools’ in Toolbox

 go to the bottom of the list and choose ‘Set toolbox visibility’.

 The select the new Profile.

 The new Profile can now be used.

We now use the profile

FUNCTIONS
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Example: Create a Pedigree/Stamboom Profile

 Create the Actor ‘FAMILY’
 Create the Relations:

 Create a Location:
 Create a Relation: 

FUNCTIONS
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Example: Create a Pedigree/Stamboom Profile

FUNCTIONS
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Example: Create a Pedigree/Stamboom Profile

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 146p.

Working with Baselines (1)

Enterprise Architect provides a facility to create a Baseline or 'snapshot' of the
contents of a selected package and its child packages at a particular point in time;
this enables you to later compare that branch of the model at that time with the
current state of the branch.

Baseline comparison is most useful for determining the changes made to the 
model during development compared to some Baseline saved at a crucial point -
for example the completion of a phase or version iteration. More than one Baseline 
can be stored against a single Enterprise Architect package.

Baselines are particularly useful during requirements management to check for 
changes, additions and deletions that have occurred since the start of the current 
work phase; knowing how a model has changed is an important part of managing 
change and the overall development process.

FUNCTIONS
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Working with Baselines (2)

 Make a first version of your Diagram; example

 Then save the Diagram

 Then choose for ‘ Package > Baselines ... ‘

 and select ‘New Baseline’.

 The fill in the Version number.

 The Version
number is
saved.

FUNCTIONS
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Working with Baselines (2)

 Make a first version of your Diagram; example

 Then save the Diagram

 Then choose for ‘ Design > Baselines ... ‘

 and select ‘New Baseline’.

 The fill in the Version number.

 The Version
number is
saved.

FUNCTIONS
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Working with Baselines (3)

 Make a second version of your Diagram; example

 Then go with the mouse
to the specific diagram 

 and press right mouse button and select ‘Compare
diagram to Baseline …‘

 Then select ‘Show differences’

FUNCTIONS
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Working with Baselines (4) Comparison

 By selecting field per field or ‘Check All’ you can see how each element differs 
from the Baseline.

 When you select        a field, you can restore it to the previous Baseline position.

FUNCTIONS
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Version Control in EA  (1)

Glossary

DBMS: Database Management System. A DBMS is commonly used when the
Model Repository is accessed by several concurrent users.

Model Repository: Enterprise Architect's storage mechanism for model
information. If multiple users concurrently edit the same model, the repository is
usually DBMS-based. In distributed team environments where concurrent model
access is not possible, local EAP files are usually deployed instead.
Enterprise Architect can use your Version Control System to transfer information
between the Model Repository and a Version Control Repository to propagate
changes amongst team members.

Version Control Repository: The storage mechanism used by the Version Control
System to store model revisions.

FUNCTIONS
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Version Control in EA  (2)

Glossary

Version Control System: The third-party product that manages revisions of your
model data. Enterprise Architect provides the user interface needed to move data
between the Model Repository and the Version Control Repository.

Working Copy: The set of files on your local machine that you have retrieved from
the Version Control Repository. Enterprise Architect uses your working copy files to
update the Model and Version Control Repositories.

Check-in: The process of submitting your changes to the Version Control
Repository. In Enterprise Architect, you execute this command on a Package that
you have checked out. This then updates the Version Control Repository with your
changes and releases your editing lock on that Package.

Check-out: The process of retrieving the latest version of a file from the Version
Control Repository. Executing this command from Enterprise Architect will overwrite
the selected Package with the latest version and lock that Package for your
exclusive editing.

FUNCTIONS
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Version Control in EA  (3)

In EA: open a server based project (DBMS)
Click file > Open project

Assumption: DBMS Repository, ODBC Data source (contains information about
how to connect to the DBMS Repository) are setup. See Handleiding EA
Repositories how to do this

Click on 
Connect 
to server

Click on 
Connect 
to Cloud

FUNCTIONS
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Version Control in EA  (4)

In EA: open a server based project (DBMS)

Select 
ODBC Driver

2. Click on 
Next

3. Select data
Source Name

4. Enter
Catalog

4. Finish

FUNCTIONS
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Version Control in EA  (5)

In EA: open a server based project 
(DBMS)

 A dialog box will open where a unique 
name can be given to the project

 Change proposed name (if necessary) 
and click on OK

 Project will be opened (visible in project 
browser) and ready to use

FUNCTIONS
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Version Control in EA  (6)

In EA: open a server based project 
(DBMS)

Package with
version control

(checked in)

Package without
version control

Package with
version control 
(checked out)
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Version Control in EA  (7)

In EA: Bringing a package under version control
Select package,  right click en select package control > add branch to Version 
Control

Assumption: Version control Repository, working directory are setup. See
Handleiding EA Repositories how to do this.
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Version Control in EA  (8)

In EA: Checkout/checkin a package
- Select package,  right click en select package control > checkout
- Select package,  right click en select package control > checkin
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URLs:

http://www.sparxsystems.com.au/resources/demos/

http://www.sparxsystems.com.au/resources/webinar/webinar-
series.html

https://www.youtube.com/user/SparxSystems

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 160p.

URLs:

User Groups:

In 2014, user group meetings supported by Sparx have taken place in
Germany, the Netherlands, Canada and the UK - bringing together the best in
knowledge around Sparx EA. More meetings will be announced for 2015 at:

http://www.eausergroup.com/

The Enterprise Architect community site has grown solidly, surpassing 14,000
members in 2014. This community has been a continual, trusted source of
information for its members.

http://www.community.sparxsystems.com/

FUNCTIONS



Copyright  GIJSELSDOTCOM - THE INSTITUTE   /  www.TheInstitute.be   /  info@TheInstitute.be 161p.

Enterprise Architect is a trademark 
of Sparx Systems PTY LTD.
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